Netzwerkanalyse, Fehlersuche, Testberichte
Home / News
Netzwerkanalyse
Grundlagen
Verkabelung
Erste Schritte
Baselining
Let's sniff
Tools
Auswerten/Filtern
Typische Probleme 1
Typische Probleme 2
Sicherheit
Bücher
Tutorials
Cacti
DSL einrichten
DynDNS einrichten
m0n0wall | pfSense
Nmap
VirtualBox
Wireshark
Forum
Shop
FAQ
Know How
Testberichte
Hardware-DB
Events
Netzwerklexikon
Links / Service
Suche
Kontakt
Impressum
Feedback
Sitemap
Partner
Unser Partner für
SSL Zertifikate
ist Checkdomain GmbH.
Netzwerktechnik Forum

Forum Netzwerktechnik (Archiv)

Kategorie Netzwerktechnik - Forum Tools

 
wireshark interfaces werden nicht angezeigt

geschrieben am 10.05.2010 um 18:18 von raybeeger

Ich habe wireshark unter Mac OS X11 installiert und auch, entsprechend den Anweisungen, die erforderlichen Menues : Library/StartupItems/ChmodBPF inklusive der ChmodBPF, Readme.macosx, StartupParameters.plist eingerichtet. Es gelingt mir trotzdem nicht, mit den erforderlichen admin-Rechten wireshark zum Laufen zu bringen, weil weiterhin die interfaces fehlen. Kann mir jemand helfen? Ich bin ein ziemlicher Mac-Neuling und habe noch nicht mit dem Terminal-Programm direkt gearbeitet.
 

geschrieben am 11.05.2010 um 06:58 von Mirko

Gib im Terminal mal

Code:
ls -l /dev/bpf*


ein und poste die Ausgabe.

Mirko
 

geschrieben am 13.05.2010 um 12:08 von raybeeger

Re: wireshark interfaces werden nicht angezeigt

"raybeeger" wrote:
Ich habe wireshark unter Mac OS X11 installiert und auch, entsprechend den Anweisungen, die erforderlichen Menues : Library/StartupItems/ChmodBPF inklusive der ChmodBPF, Readme.macosx, StartupParameters.plist eingerichtet. Es gelingt mir trotzdem nicht, mit den erforderlichen admin-Rechten wireshark zum Laufen zu bringen, weil weiterhin die interfaces fehlen. Kann mir jemand helfen? Ich bin ein ziemlicher Mac-Neuling und habe noch nicht mit dem Terminal-Programm direkt gearbeitet.


Hallo Mirko, danke für die Antwort. Ich bekam folgende Anzeige:

/dev/bpf0
/dev/bpf1
/dev/bpf2
/dev/bpf3
 

geschrieben am 13.05.2010 um 12:10 von Mirko

So sieht die Ausgabe vom "ls -l" aus? Fehlt da nicht was?

Mirko
 

geschrieben am 13.05.2010 um 14:37 von raybeeger

"Mirko" wrote:
So sieht die Ausgabe vom "ls -l" aus? Fehlt da nicht was?

Mirko


Das ist das was ich gemacht habe (Sternchen = user name):

*********-iMac:~ *********$ ls -1 /dev/bpf*
/dev/bpf0
/dev/bpf1
/dev/bpf2
/dev/bpf3
*********-iMac:~ *********$

Mehr kam dabei nicht heraus!?

Gruß
Ray
 

geschrieben am 13.05.2010 um 17:44 von Mirko

Der Parameter vom ls ist ein kleines l wie long. Dann sollte die Ausgabe anders aussuehen.

Mirko
 

geschrieben am 14.05.2010 um 00:55 von raybeeger

"Mirko" wrote:
Der Parameter vom ls ist ein kleines l wie long. Dann sollte die Ausgabe anders aussuehen.

Mirko


Hallo Mirko,

ich hatte beide Varianten ausprobiert und das ist das Ergebnis mit "l":

Last login: Fri May 14 00:54:52 on ttys000
mac:~ **********$ ls -l dev/bpf*
ls: dev/bpf*: No such file or directory
mac:~ **********$

Das sah für mich noch schlechter aus...

Ray
 

geschrieben am 14.05.2010 um 06:51 von Mirko

Da fehlt jetzt ein Slash / vo dem dev
 

geschrieben am 14.05.2010 um 12:33 von raybeeger

"raybeeger" wrote:
"Mirko" wrote:
Der Parameter vom ls ist ein kleines l wie long. Dann sollte die Ausgabe anders aussuehen.

Mirko


Hallo Mirko,

ich hatte beide Varianten ausprobiert und das ist das Ergebnis mit "l":

Last login: Fri May 14 00:54:52 on ttys000
mac:~ **********$ ls -l dev/bpf*
ls: dev/bpf*: No such file or directory
mac:~ **********$

Das sah für mich noch schlechter aus...

Ray


Danke! Learning by doing...

Hallo Mirko,

hier das Ergebnis:

mac:~ ********$ ls -l /dev/bpf*
crw------- 1 root wheel 23, 0 14 Mai 12:34 /dev/bpf0
crw------- 1 root wheel 23, 1 14 Mai 12:34 /dev/bpf1
crw------- 1 root wheel 23, 2 12 Mai 21:02 /dev/bpf2
crw------- 1 root wheel 23, 3 12 Mai 21:02 /dev/bpf3
 

geschrieben am 14.05.2010 um 15:56 von Mirko

Jetzt passt die Ausgabe. Da stimmen aber die Rechte auf den Interfaces nicht. Wie sieht denn /Library/StartupItems aus? Poste mal die Ausgabe von

ls -l /Library/StartupItems/

und

ls -l /Library/StartupItems/ChmodBPF/

Mirko
 

geschrieben am 14.05.2010 um 16:46 von raybeeger

"Mirko" wrote:
Jetzt passt die Ausgabe. Da stimmen aber die Rechte auf den Interfaces nicht. Wie sieht denn /Library/StartupItems aus? Poste mal die Ausgabe von

ls -l /Library/StartupItems/

und

ls -l /Library/StartupItems/ChmodBPF/

Mirko


mac:~ ******$ ls -l /Library/StartupItems/
total 0
drwxr-xr-x 4 root wheel 136 18 Feb 11:48 TCNear
mac:~ *******$

mac:~ ******$ ls -l /Library/StartupItems/ChmodBPF/
ls: /Library/StartupItems/ChmodBPF/: No such file or directory
mac:~ ******$

Hallo Mirko,

das mit den Rechten ist mir schon bewusst, jedoch habe ich, wie oben beschrieben, die Pfade und Dateien ja im Finder "richtig" angelegt.

Aber hier bist Du ja der Fachmann und ich noch fast ahnungslos! Wenn Du mal was über Milch oder Käse wissen willst... Ich arbeite bei TETRA PAK und baue Molkereianlagen ;-)

Ray
 

geschrieben am 16.05.2010 um 10:22 von Mirko

Im Ordner StartupItems fehlt der Ordner ChmodBPF.

Du musst dazu den Ordner Startup aus dem Wireshark.dmg nach StartupItems kopieren und umbenennen. Das Script in diesem Ordner wird dann beim Systemstart ausgeführt und setzt die Berechtigungen auf den Netzwerkschnittstellen.

Mirko

PS: Milch und Käse sind auch ein interessantes Thema. Da bin ich aber eher Konsument.
 

geschrieben am 17.05.2010 um 07:24 von raybeeger

"Mirko" wrote:
Im Ordner StartupItems fehlt der Ordner ChmodBPF.

Du musst dazu den Ordner Startup aus dem Wireshark.dmg nach StartupItems kopieren und umbenennen. Das Script in diesem Ordner wird dann beim Systemstart ausgeführt und setzt die Berechtigungen auf den Netzwerkschnittstellen.

Mirko

PS: Milch und Käse sind auch ein interessantes Thema. Da bin ich aber eher Konsument.


Hallo Mirko,

das hatte ich schon erledigt. Im wireshark.dmg gibt es in der mir vorliegenden Version keinen Ordner "Startup". Unter "Utilities sind folgende Ordner vorhanden: ChmodBPF, Command Line und StartupItems (mit einem klienen Pfeil links unten im Ordnersymbol - wahrscheinlich Verknüpfung).

Im ChmodBPF-Ordner: ChmodBPF, README.macosx, StartupParameters.plist

In Command Line: capinfos, dftest, dumpcap, editcap, idl2wrs, mergecap, randpkt, rawshark, text2pcap, tshark, wireshark

StartupItems: ist die Verknüpfung für den Autostart, dort wird mein externes Soundmodul (firewire TCNEAR) angezeigt, wenn ich es anklicke.

Den Ordner ChmodBPF hatte ich, wie zu Beginn geschrieben, in den von mir neu angelegten Ordner: StartupItems kopiert. Müssen ggf. die anderen Ordner mit dazu eingetragen werden? Das wäre irgendwie logisch.

Seltsam ist auch, dass die Verknüpfung: StartupItems das Soundmodul aufruft...
 

geschrieben am 17.05.2010 um 20:00 von Mirko

Da haben sich vermutlich die Ordnernamen geändert, muss ich bei Gelegenheit mal unter Mac OS testen.

Nimm mal den Ordner ChmodBPF und kopiere ihn in die StartupItems.

Mirko
 

geschrieben am 22.07.2010 um 13:39 von cornelius.heggli

Hallo Mirko

Hast du das mal getestet unter dem aktuellen Mac OS?

Nach dem Neustart bekomme ich die Fehlermeldung, dass dieses Startobjekt nicht "sicher" sei und deaktiviert werde. Wie kann ich das umgehen?

Wenn ich das Script ChmodBPF manuell ausführe bekomme ich folgende Fehlermeldung im Terminal;
/Library/StartupItems Disabled/ChmodBPF/ChmodBPF: line 35: $1: unbound variable
Hab das Script mal angeschaut und gesehen, dass diese Variable nur dort vorkommt... ???!?!!??!?

Habe die beiden Modifikationen
chgrp .....
chmod ....
mal direkt im Terminal als sudo ausgeführt und konnte somit bis zum Reboot des Macs problemlos rumsniffern. Aber nach dem Neustart sind die Rechte wieder auf dem alten Stand.

Kannst du mir weiterhelfen?
 

geschrieben am 23.07.2010 um 06:27 von Mirko

Du solltest beim Starten die Möglichkeit haben, die Sicherheitseinstellungen des Startobjektes anzupassen:

http://support.apple.com/kb/HT2413?viewlocale=de_DE&locale=de_DE

Dann sollte OSX das Startobjekt beim nächsten Booten ohne Rückfrage ausführen.

Mirko
 

[ Dieses Thema im Live-Forum aufrufen ]

Sie befinden sich im Archiv des Forums.
Zum Forum

Archiv erstellt mit phpBB2HTML 0.1 - Foren in statisches HTML umwandeln © 2006 Mirko Kulpa

 

 
© 2004-2015, network lab - we make your net work - Netzwerkforum
aktualisiert am 15.12.2017