Netzwerkanalyse, Fehlersuche, Testberichte
Home / News
Netzwerkanalyse
Grundlagen
Verkabelung
Erste Schritte
Baselining
Let's sniff
Tools
Auswerten/Filtern
Typische Probleme 1
Typische Probleme 2
Sicherheit
Bücher
Tutorials
Cacti
DSL einrichten
DynDNS einrichten
m0n0wall | pfSense
Nmap
VirtualBox
Wireshark
Forum
Shop
FAQ
Know How
Testberichte
Hardware-DB
Events
Netzwerklexikon
Links / Service
Suche
Kontakt
Impressum
Feedback
Sitemap
Partner
Unser Partner für
SSL Zertifikate
ist Checkdomain GmbH.
Netzwerktechnik Forum

Forum Netzwerktechnik (Archiv)

Kategorie Netzwerktechnik - Forum Tools

 
cacti frage

geschrieben am 01.10.2008 um 09:46 von hoffi-

Hallo
ich hab mir gerade die aktuelle cacti version auf debian etch installiert. klappt auch erstmal gut. nur beim anlegen der eigenen graphs zeigt cacti keine bilder sondern nur platzhalter. bei dem mitgelieferten local bsp. zeigt es alles gut an.

hat einer einen tipp was ich aendern kann ?

mfg
hoffi-
 

geschrieben am 01.10.2008 um 17:54 von Mirko

Was steht im Log? Kommt eine Fehlermeldung in den Einstellungen für den Graph?

Mirko
 

geschrieben am 02.10.2008 um 08:09 von hoffi-

im cacti.log steht:

09/11/2008 01:35:04 AM - CMDPHP: Poller[0] Host[1] No host availability check possible for '127.0.0.1'.
09/11/2008 01:35:04 AM - CMDPHP: Poller[0] Host[1] DS[3] CMD: perl /usr/share/cacti/site/scripts/linux_memory.pl MemFree:, output: 307748
09/11/2008 01:35:05 AM - CMDPHP: Poller[0] Host[1] DS[4] CMD: perl /usr/share/cacti/site/scripts/linux_memory.pl SwapFree:, output: 1510068
09/11/2008 01:35:05 AM - CMDPHP: Poller[0] Host[1] DS[5] CMD: perl /usr/share/cacti/site/scripts/loadavg_multi.pl, output: 1min:0.33 5min:0.37 10min:0.16
09/11/2008 01:35:05 AM - CMDPHP: Poller[0] Host[1] DS[6] CMD: perl /usr/share/cacti/site/scripts/unix_users.pl , output: 1
09/11/2008 01:35:05 AM - CMDPHP: Poller[0] Host[1] DS[7] CMD: perl /usr/share/cacti/site/scripts/unix_processes.pl, output: 64
09/11/2008 01:35:07 AM - CMDPHP: Poller[0] Time: 2.8099 s, Theads: N/A, Hosts: 3
09/11/2008 01:35:08 AM - SYSTEM STATS: Time:4.3972 Method:cmd.php Processes:1 Threads:N/A Hosts:4 HostsPerProcess:4 DataSources:7 RRDsProcessed:5


im cacti ist fuer mich kein fehler ersichtlich.

ich seh daraus nicht warum die localen bsp. angezeigt werden aber mein eigen erstellter graph nicht.

danke im voraus fuer eure hilfe
 

geschrieben am 03.10.2008 um 10:17 von Mirko

Was möchtest Du denn in dem eigenen Graph darstellen? Hast Du eine Data Source angelegt? Klicke in der Data Source mal auf "Turn On Data Source Debug Mode". Dann solltest Du den Namen des RRD-Files sehen. Prüfe mal, ob diese Datei vorhanden ist.

Mirko
 

geschrieben am 06.10.2008 um 14:30 von hoffi-

guter tipp

das mit Turn Off Graph Debug Mode war ein super tipp. es ist genau wie du vermutet hast es fehlt das rrd-file. muss ich das haendisch anlegen oder hab ich was mit den berechtigungen falsch gemacht oder wo hab ich was vergessen ??

thx auf jedenfall fuer die hilfe bis hierher ;O)

hoffi-
 

geschrieben am 06.10.2008 um 18:56 von Mirko

Manchmal legt Cacti das RRD-File nicht an. Geh mal in der Datenquelle auf Turn On Data Source Debug Mode. Dann wird unten der Code für die Erstellung angezeigt. Sieht etwa so aus:

Code:
/usr/bin/rrdtool create \
/usr/share/cacti/site/rra/arcor_1st_hop_ping_37.rrd \
--step 300  \
DS:ping:GAUGE:600:0:5000 \
RRA:AVERAGE:0.5:1:600 \
RRA:AVERAGE:0.5:6:700 \
RRA:AVERAGE:0.5:24:775 \
RRA:AVERAGE:0.5:288:797 \
RRA:MAX:0.5:1:600 \
RRA:MAX:0.5:6:700 \
RRA:MAX:0.5:24:775 \
RRA:MAX:0.5:288:797 \


Diesen Code einfach in der Shell ausführen um das RRD-File anzulegen.

Mirko
 

geschrieben am 06.10.2008 um 22:11 von hoffi-

thx

danke du hast mir sehr geholfen ... klappt

mfg
hoffi-
 

[ Dieses Thema im Live-Forum aufrufen ]

Sie befinden sich im Archiv des Forums.
Zum Forum

Archiv erstellt mit phpBB2HTML 0.1 - Foren in statisches HTML umwandeln © 2006 Mirko Kulpa

 

 
© 2004-2015, network lab - we make your net work - Netzwerkforum
aktualisiert am 22.10.2017