Netzwerkanalyse, Fehlersuche, Testberichte
Home / News
Netzwerkanalyse
Grundlagen
Verkabelung
Erste Schritte
Baselining
Let's sniff
Tools
Auswerten/Filtern
Typische Probleme 1
Typische Probleme 2
Sicherheit
Bücher
Tutorials
Cacti
DSL einrichten
DynDNS einrichten
m0n0wall | pfSense
Nmap
VirtualBox
Wireshark
Forum
Shop
FAQ
Know How
Testberichte
Hardware-DB
Events
Netzwerklexikon
Links / Service
Suche
Kontakt
Impressum
Feedback
Sitemap
Partner
Unser Partner für
SSL Zertifikate
ist Checkdomain GmbH.
Netzwerktechnik Forum

Forum Netzwerktechnik (Archiv)

Kategorie Netzwerktechnik - Forum Netzwerkprotokolle und Dienste

 
Welche SNMP-Version benötigt eine bestimmte MIB

geschrieben am 04.01.2010 um 07:50 von famp2010

Moin!

ich beschäftige mich gerade ganz neu mit SNMP und bin dabei auf ein Problem gestoßen: SNMP beschreibt ja nur die Datenübertragung d.h. es definiert NICHT die verfügbaren Objekte. Die Objekte selber werden ja über die MIB (Management Information Base) festgelegt. Wenn meine Anwendung nun eine bestimmte MIB unterstützen soll, woher weiß ich dann welche SNMP-Version (1,2,3) ich implementieren muss? Oder kann ich prinzipiell jede MIB in jeder Version umsetzen?
Vielen Dank!
 

geschrieben am 04.01.2010 um 08:18 von Otaku19

die MIB sind ISO/Herstellerbezogen, das hat nichts mit der Art der Abfrage zu tun.

Securitytechnisch ist v3 natürlich klar vorzuziehen.

Wenn du selber MIBs erstellen willst musst du dich mit dem "MIB Baum" auseinandersetzen, der ist recht komplex
 

geschrieben am 05.01.2010 um 08:25 von famp2010

Hallo Otaku19. Vielen Dank für deine Antwort. Eine MIB sagt also nichts über die verwendete SNMP-Version aus. Woher weiß nun aber ein Manager mit welcher SNMP-Version er eine Anfrage an eine Gerät stellen muss? Muss dann also eine Netzwerkkomponente die alle Versionen unterstützen soll 3 Agenten für eine MIB (z.B. für MIB-II) implementieren?
Irgenwie fehlt mir hier noch der Durchblick...

Gruß
 

geschrieben am 05.01.2010 um 09:32 von Otaku19

das entscheidet sich danach was auf den Komponenten konfiguriert ist, SNMP ist in aktuellen Geräten (hoffentlich) nicht vorkonfiguriert, egal welche Version. Die Zeiten wo v1 automatisch mit den Communitys public und private aktiv war sind vorbei.

Ich empfehle bei Neuinstallationen gleich v3 zu verwenden, klar ist es "umständlicher" aber eben auth/priv
 

[ Dieses Thema im Live-Forum aufrufen ]

Sie befinden sich im Archiv des Forums.
Zum Forum

Archiv erstellt mit phpBB2HTML 0.1 - Foren in statisches HTML umwandeln © 2006 Mirko Kulpa

 

 
© 2004-2015, network lab - we make your net work - Netzwerkforum
aktualisiert am 23.10.2017